DisplayPort Screen Blank after Boot or Sleep with Asus STRIX GTX 970 Series

Seems there’s an issue with the Asus Strix GTX 970 card when using specifically the DisplayPort (DP) connector on certain monitor models.

Symptoms

I found my screen (Dell U2713H) would suggest there was “No Signal” coming from the PC at certain times. More confusingly, intermittently;

  • Black screen/No Signal when first turning on the PC
  • Black screen/No Signal when resuming from Sleep
  • Black screen/No Signal between the Windows 10 boot screen and the login screen.

Solution

When you finally get it too boot without issue, you need to update the VBIOS of your graphics card.

I believe I was on version 84.04.36.00.AS15, however since updating to 84.04.84.00.AS17 I haven’t had an issue.

You can download the new VBIOS from Asus’ Support Website. It has the description “Fix DP display issue with certain monitors”

There are some older VBIOS versions too; 84.04.2F.00.AS05 & 84.04.1F.00.AS13 & 84.04.1F.00.AS08 though I can’t confirm they had the same issue.

If you need to check the version of your VBIOS, you can use the GPU Tweak II download on the same page (though don’t trust the LiveUpdate as it didn’t pick up this update).

Asus STRIX GTX970 on GPU Tweak II

 

Comments

4 Responses

  1. hey came across your post and thanks! had the problem for ages and thought my card was on its way out. Much appreciated!!

Leave a Reply

Your email address will not be published. Required fields are marked *